What iPhone models can I use BlindSquare on?

All models of the iPhone starting with the iPhone 4 support BlindSquare. However, later iPhone models have better GPS receivers, so the information provided by BlindSquare is more reliable on later models.

The GPS receiver of the iPhone 3GS is not accurate enough to let BlindSquare announce street crossings as you walk. To use BlindSquare, iOS 5 or later has to be installed on your device.

Comment on this FAQ

Your email address will not be published. Required fields are marked *